eFiling DDoS Attack

Incident Report for Business Data Group

Resolved

Between ~6:50 PM and ~10:30 PM, our system was subject to a high-intensity, widespread DDoS attack. Due to the wide-ranging span of locations the attack came from and the shifting nature of the location of the requests made against our system, our DDoS protection could not block the attack automatically.

Our out-of-hours server team jumped onto the issue at ~7 PM and began working on rules to prevent the bots from making requests. Service was restored at ~10:30 PM and further attacks through the night resulted in only periods of poor performance as opposed to complete outages.

A post-mortem report will be provided once all avenues of further prevention to ensure this cannot occur again have been explored.
Posted Oct 02, 2023 - 22:30 BST

Identified

Between ~6:50 PM and ~10:30 PM, our system was subject to a high-intensity, widespread DDoS attack. Due to the wide-ranging span of locations the attack came from and the shifting nature of the location of the requests made against our system, our DDoS protection could not block the attack automatically.

Our out-of-hours server team jumped onto the issue at ~7 PM and began working on rules to prevent the bots from making requests. Service was restored at ~10:30 PM and further attacks through the night resulted in only periods of poor performance as opposed to complete outages.

A post-mortem report will be provided once all avenues of further prevention to ensure this cannot occur again have been explored.
Posted Oct 02, 2023 - 19:00 BST
This incident affected: eFiling (Admin Area, Websites, REST API).