eFiling Admin Area Offline

Incident Report for Business Data Group

Postmortem

At approximately 7:15 AM this morning Google attempted to provision a new certificate for the eFiling admin area automatically. This provisioning failed and required manual intervention to correct. Due to the nature of certificate caching, some users will have encountered an error with the admin site at the time of the failure, whilst others will have encountered this later. The first of our monitoring tools noted the admin area's offline status at approximately 7:45 AM, which triggered an immediate response from our emergency response teams.

 

A new certificate was generated and issued immediately. It took approximately 1 hour for Google to verify, provision, and deliver it to us, at which point it was applied, restoring normal service at 9:06 AM. Our teams then monitored the system briefly to ensure that service was restored.

Posted Apr 15, 2025 - 09:29 BST

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 09:10 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2025 - 09:06 BST

Update

We are continuing to investigate this issue.
Posted Apr 15, 2025 - 09:04 BST

Investigating

We are currently investigating this issue.
Posted Apr 15, 2025 - 07:45 BST
This incident affected: eFiling (Admin Area).