An updated has been issued by the service provider and the incident is now resolved.
Posted Dec 10, 2024 - 14:38 GMT
Investigating
Mobunti's postcode lookup services are currently unavailable. As Mobunti is a third party supplier, we have contacted them to inform them of the outage and are monitoring for further updates.
Posted Dec 10, 2024 - 14:14 GMT
This incident affected: eFiling (Postcode Lookup Services).