Companies House Downtime

Incident Report for Business Data Group

Resolved

Companies House has restored its systems.
Posted Mar 23, 2023 - 09:17 GMT

Monitoring

Companies House have just announced a maintenance window taking place today between 9 AM and 8 PM. Companies House services will be completely unavailable during this time.
Posted Mar 22, 2023 - 09:31 GMT
This incident affected: eFiling (Companies House Communication).