Submissions are now being processed unhindered, albeit with a delay caused by the sudden increase from the release of all stuck applications.
We continue monitoring and working with Companies House for seriously delayed items.
Posted Jul 17, 2025 - 10:51 BST
Update
Companies House has advised that all stuck applications are now filtering through their system and will be incorporated in due course.
This represents a significant number of companies and is likely to take some time for them to process.
We will continue to provide updates if any are required.
Posted Jul 15, 2025 - 16:49 BST
Update
We continue to liaise with Companies House regarding the ongoing delays and submission issues.
Presently, Companies House are aware that companies from last week, predominantly on the 9th of July, are still in a processing state and are actively working towards a resolution.
Their technical teams are collating all affected companies and intend to issue an update as soon as possible to release them from their current limbo state.
There is currently no timeline for this resolution. We are pushing Companies House at several touchpoints throughout the day for an update or guidance on when a resolution can be expected. Still, thus far, no further details have been forthcoming.
As soon as more information is available, we will post further updates and notify clients as appropriate.
Posted Jul 15, 2025 - 10:48 BST
Monitoring
Companies House is experiencing delays currently caused by a combination of a 24-hour maintenance window and issues processing company formation charges towards the end of last week.
We are aware of and monitoring an approximate 48-hour delay on company submissions.
Unfortunately, this is outside of our control to resolve. We must wait for Companies House to catch up on the delayed companies.
Posted Jul 14, 2025 - 12:14 BST
This incident affected: eFiling (Companies House Communication).