Admin Area - Inaccessible (eFiling)

Incident Report for Business Data Group

Postmortem

eFiling increased the level of data encryption back in December 2020, this update introduced a new cryptography library to the system.

At 3:18pm on 09/03/2021 an infrequently used part of the Business Data Group admin portal was used that triggered an invalid cryptographic hash to be stored in the database. When accessing the admin area after this, an unrecoverable error was produced resulting in the admin area becoming in accessible.

The Business Data Group monitoring software alerted the technical team who responded immediately, and the error was resolved at approx. 3:28pm. A full review of the system was then carried out to ensure there will be no repeat.

Posted Mar 11, 2021 - 09:56 GMT

Resolved

We are currently investigating this issue.
Posted Mar 09, 2021 - 15:18 GMT