Disruption to User Sessions (eFiling)

Incident Report for Business Data Group

Postmortem

Summary

In preparation for another security update that will be released next month, a new version of code was deployed into production at 8:50am (BST) this morning. This update changes the implementation of user sessions across the admin area and brand websites. As a result, user session data was duplicated.

A fix was deployed at 9:40am (BST)

Impact

This would have impacted Admin and Web users differently.

Admin users

If your brand has multiple installations of eFiling, admin users would have experienced trouble switching brands and would have been 'stuck' on the brand they last accessed pre-release. Admin users may also be unable to dismiss the Terms and Conditions banner at the top of the admin area.

Web users

All customers should remain unaffected. The user sessions were duplicated which means the current active order and user state remain the same. As soon as the order is completed at end of the order form, the duplicate sessions will be removed.

Action required

No action is required as of 9:40am (BST).

If an admin or web users experiences any trouble accessing the order form, It’s recommended that the user logs out and back in to continue their order as this will guarantee a new session has been started.

Posted Oct 21, 2020 - 13:18 BST

Resolved

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2020 - 09:45 BST